Deployment Performance Degraded for AWS Middle East Region resources

Incident Report for Sonrai

Resolved

AWS has moved this to resolved.
Posted Mar 09, 2026 - 15:39 UTC

Update

Update 3/3/2026: AWS is still heavily impacted and throttled in these Availability Zones's.
Posted Mar 03, 2026 - 16:05 UTC

Identified

Those clients with resources in AWS Availability Zones's me-central-1 and me-south-1 may be experiencing degraded deployment performance due to the ongoing outages in these AWS AZ's. We will continue to monitor AWS for a resolution to these issues and update this incident accordingly.
Posted Mar 02, 2026 - 14:59 UTC
This incident affected: Cloud Permission Firewall (Deployment Controls).